Quickpay - Trustly - Service Disruption – Incident details

Trustly - Service Disruption

Resolved
Degraded performance
Started 3 days agoLasted 39 minutes

Affected

API

Operational from 7:16 AM to 7:55 AM

Payment

Degraded performance from 7:16 AM to 7:55 AM

3rd party services

Degraded performance from 7:16 AM to 7:55 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Please be informed that an external issue has been identified which is affecting Trustly payment method for Germany.

    Our teams are in close cooperation with the external provider and we are waiting their findings and resolution steps.