Quickpay - Delay issue on payments with MobilePay Online – Incident details

Delay issue on payments with MobilePay Online

Resolved
Degraded performance
Started 4 days agoLasted 2 days

Affected

3rd party services

Degraded performance from 7:57 AM to 12:09 AM, Operational from 12:09 AM to 7:51 AM

Updates
  • Resolved
    Resolved

    We sincerely apologize for any inconvenience caused by the recent issues with MobilePay payments. We have not observed any new developments and are confident that this matter is now resolved. Thank you for your patience and understanding.

  • Monitoring
    Monitoring

    We are monitoring the results of the fixes we've implemented.

    The result of the issue will have caused the consumer to have experienced an error in the payment flow in their MobilePay app, even though the payments have succeeded in the background towards the bank.

    This may well have caused the consumers to have placed multiple orders throughout the day. We therefore strongly encourage you to double check if there are any duplicate orders from the same customer in your store.

    During the time of the incident, we also experienced periodic hiccups related to all services, which seems to have caused captures to get stuck in a "pending" state. If you are experiencing any of these cases, please double check with your acquirer to confirm that the capture has actually gone through.


    We apologize for the inconvenience we may have caused you,

    Quickpay Team






  • Identified
    Update

    The issues has been identified as related to the main database. In order to help solve the issue, a reboot of the database is required, which we will be doing later tonight at the scheduled maintenance. This is due to the reboot requiring the entire infrastructure to be briefly unavailable, including other transactions and action currently not affected by this issue.

  • Identified
    Update
    We are continuing to work on a fix for this incident.
  • Identified
    Identified

    We have located the issues related to the delay in callbacks specifically for MobilePay transactions, which causes them to fail in the MobilePay App. We are continuing to work on a fix for this incident.

    We are still seeing transactions being processed for MobilePay, however in a limited amount than expected.

  • Investigating
    Investigating

    We're currently investigating delays in payments with MobilePay Online.