Quickpay - Phone and mail support – Incident details

Phone and mail support

Resolved
Major outage
Started 8 days agoLasted 20 minutes

Affected

Quickpay Support Mail

Major outage from 8:57 AM to 9:17 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Our supplier for our phone and mail system (Cloudflare) currently have problems so we cannot be reached by phone currently. Mails will still go through but might have delayed response times.