Resolved: Problems with ViaBill payment methods Thursday 19th November 2020 12:53:00 UTC


Update: the operation is back to normal again

We are experiencing problems with ViaBill payment method.

We are investigating and working with ViaBill on fixing the issue.

Best regards, QuickPay