Resolved
3-D Secure service is experiencing problems

Started
July 08, 2022 at 10:03 AM
Status
Resolved after about 24 hours
Affected
3rd party services

Impact

Degraded performance
  • Resolved
    July 09, 2022 at 10:03 AM

    The 3-D Secure service is back to normal

  • Monitoring
    July 08, 2022 at 10:03 AM

    Some transactions are currently getting stuck through the 3-D Secure process.

    The problem is caused by network issues outside of Quickpay scope.

    We are monitoring the situation.