Quickpay - Problems with our online systems – Incident details

Problems with our online systems

Resolved
Partial outage
Started 30 days agoLasted 13 minutes

Affected

Payment

Partial outage from 9:05 AM to 9:18 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are experiencing problems with our online systems. Some transactions are refused.

    The problem seems to be focused towards payments through the Nets acquirer.

    We are investigating and working on fixing the issue.

    Best regards, QuickPay