Quickpay - Support phone – Incident details

Support phone

Resolved
Operational
Started 2 days agoLasted about 2 hours

Affected

Quickpay Support Mail

Operational from 9:44 AM to 11:56 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are having some problems with some calls failing when we try to pick them up. So if you have problems reaching us by phone please send us an email at support@quickpay.net