Resolved
Quickpay Manager is not accessible

Started
May 31, 2023 at 6:56 AM
Status
Resolved after 27 minutes

Impact

Major outage
Affected
manage.quickpay.net
  • Resolved

    This incident has been resolved by rollback.

  • Monitoring

    We implemented a fix and are currently monitoring the result.

  • Identified

    The Quickpay Manager is currently not accessible.

    We are working on a fix